This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Soft ware queries
#11
Just a note, the name to include is VirtualWire.h
Capital letters makes difference. This is why I asked for a copy/paste of the error.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply
#12
hi I am really sorry for confusing you virtualwire.h has been there all the time it was me not reading my writing properly.

sorry
tyntop.

HI I am still getting error that some files are read only, I do not know why, I have had this come up on 2 pc's 1 with win xpsp3 and the second with win 8. I have checked files after downloading them by opening zipped file and looking at each individual file within the folders and some of them are coming up as "read only" when clicking on properties.

I don't know weather it is me doing something wrong or my pc setup.

again thanks for your replies

regards
tyntop
Reply
#13
I never seen Arduino IDE complain about read only files. Can you please copy / paste the message with the error?
What files are causing the error? Try to be more specific.

The Arduino IDE only read library files, never write anything to any of those folders. So, read only files in libraries folders can't be the problem

Where you put the WeatherDuino_RX_v013_b014 files?
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply
#14
Hi it's me again, and I am really very sorry for being a pain, but do you know what would be really handy, if you did a youtube type video showing us step by step how to use the arduino software. Varifying, compiling and uploading, then hopefully I and other people if they are having problems could see where we are going wrong.
I have been on a pc for at least 6-7hrs tonight and I cant work out where I am going wrong. I have finished building this project and it would be a shame if I cant get it working, I have been on this forum for hours over the last few months trying to get a better understanding of how this project works.

regards
tyntop.
Reply
#15
Surely you can find many videos on YouTube about installing and compiling programs with the Arduino IDE. Explain how this is done is beyond the scope of this project. Overall install and compile a Arduino program is very easy, something must be wrong with your installation or permissions on your computer.

What I suggest you is to uninstall all. Download the Arduino IDE again, but this time, download the 1.6.0 Windows ZIP file version for non admin install.

Unzip to a folder C: / Arduino
Install the WeatherDuino libraries as indicated some topics ago. If the folders do not exist, create them.

Also in Documents, create a folder with the name WeatherDuino, place the WeatherDuino Pro2 software folders, within this.
Go to folder WeatherDuino_RX_v013_b014, doudle click on WeatherDuino_RX_v013_b014.ino
Arduino IDE should open, edit ONLY user configurable options, and make upload.

Never edit any files outside the Arduino IDE.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply
#16
Tyntop, I hope you've now got Arduino IDE working properly. I found it can be a little difficult setting up for the first time, but once sorted out, everything works fine.

I think you're also in the UK so if you are still having problems, please don't give up as it's certainly something very simple, I will be happy to speak with you by phone and see if we can sort it out.

Allan
Reply
#17
Hi, its me again the saga continues I tried what you said but still no joy error massage came up as follows :

WeatherDuino_RX_v013_b014.ino :28:58:fatal error : VirtualWire. h : No such file or directory
compilation terminated
Error compiling

I'm starting to pull my hair out now, as I can't see where I am going wrong,
I did try to copy and paste error from aduino but it wont let do that for some reason.
Also when trying to run arduino it said it needed java which was installed, error message above was returned after java was installed

just thought i'd update you. TX and RX are now finished building wise so just got to get this software sorted

regards
tyntop
Reply
#18
Be cool you are almost there...

Go to your Arduino IDE preferences:
File -> Preferences

edit or change Sketchbook location to:

C:\Users\YOUR_NAME\Documents\Arduino
or browse to the Arduino folder in your Documents folder.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply
#19
Hi a bit more help wanted please, in arduino software what programmer should i use. As I am getting :

avrdude: stk500_recv() : programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x01
problem uploading to board

This happens after clicking upload, it seems to compile ok (got through that problem, but dont know how ) and then goes through attempts 1 - 10, when trying to upload to board.

seems that I am nearly there now so thanks to the input from you all who have responded

regards
tyntop
Reply
#20
The programmer should be ok without a change, anyway, I'm using AVRISP mkII

Best regards

(18-02-2015, 22:33)tyntop Wrote: Hi a bit more help wanted please, in arduino software what programmer should i use. As I am getting :

avrdude: stk500_recv() : programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x01
problem uploading to board

This happens after clicking upload, it seems to compile ok (got through that problem, but dont know how ) and then goes through attempts 1 - 10, when trying to upload to board.

seems that I am nearly there now so thanks to the input from you all who have responded

regards
tyntop
Reply




Users browsing this thread: 1 Guest(s)