This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with Pro2 Compact + Auriol HT13726 temperature and humidity sensor and full
#1
Hello WeatherDuino friends,
I have a Pro2 Compact with sensors of the Auriol HT13726 weather station. I have problems with the temperature and humidity sensor, apparently they are not recognized in between or show values ​​in the three-digit minus or plus range. I wanted to play with the settings of the configuration files something, while the Duino is always flashed again. After flashing a few times, the Arduino IDE tells me that the memory is full even though I have selected to clear memory in the board configuration. I have tried the software via OTA and USB to flash, but now I can not continue. Can someone help me with the problems with the sensors and the flash process?

greetings
WeatherDuino Pro2 Compact + Auriol HT13726
Reply
#2
Hi,

To receive data from the Auriol HT13726 weather station on the Pro2 Compact receiver, these settings are mandatory:

Code:
// --------------------------------------------------------------------------------------
//   Define the source of your main outside sensors
// --------------------------------------------------------------------------------------
// ---- If you are using just one TX board, the source for all items should be equal to your single TX Unit ID (most likely zero).
// ---- Define the source of your main Temperature / Humidity sensor
#define TH_SOURCE       3   // 0= Temp/Hum sensor connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Temp / Hum
// ---- Define the source of your Main Wind sensor
#define WIND_SOURCE     3   // 0= Wind instruments connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Wind Speed & Dir
// ---- Define the source of your main Rain Gauge
#define RAIN_SOURCE     3   // 0= Rain Gauge connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Rain Gauge
// ---- Define the source of your main Solar Radiation sensor
#define SOLAR_SOURCE    9   // 0= Solar Radiation sensor connected to TX_Unit 0, 1= for TX_Unit1, ..., 9 for not used
// ---- Define the source of your main UV sensor
#define UV_SOURCE       9  // 0= UV sensor connected to TX_Unit 0, 1= for TX_Unit1, ..., 9 for not used

Regarding programming, make sure you are compiling for the right board: LOLIN (WeMos) D1 R2 & mini
There is no need to erase the whole flash memory every time you do any change on the settings and upload the code. Indeed it is not recommended. On "Erase Flash" choose "Only Sketch"
Since the flash was erased, before uploading the code you need to upload fonts and icons to SPIFFS, make sure there is space reserved for it: Flash size "4M(1M SPIFFS)"
For this task use the “ESP8266 Sketch Data Upload” menu option in the Arduino IDE. If you don't have this option in your Arduino IDE, please refer to WeatherDuino Wiki: LOLIN (WeMos) D1 R2 & mini. How to upload files to the SPIFFS memory?

Do all those steps by USB, later you can upgrade by OTA.

Rgs
Reply
#3
I have the Arduino IDE and libraries again completely reinstalled under Windows 10, set up and configured according to instructions. Following flashed the WeMos via USB, the same problem as before, sometimes the temperature values fit, sometimes they go into the minus or plus range, sometimes no values are displayed. The Auriol weather station displays "correct" values.
I'll post a couple of screenshots to the post, maybe someone can tell me what it's all about. Also, with  Weatherunderground PWS , there's a big gap in the data as if the sensors were not transmitting, can not be, because the Auriol weather station always displays data.

The memory prompt did not reappear.


Attached File(s) Image(s)
           

.txt   Config_Options.txt (Size: 24,71 KB / Downloads: 8)
WeatherDuino Pro2 Compact + Auriol HT13726
Reply
#4
Can you activate the Auriol debug messages as the bottom of the config options and see what the serial monitor of arduino is showing?

regards,
engolling
Reply
#5
Hi Sun_Dancer,

Please download latest WeatherDuino Pro2 Compact (v3.2_b002) software and install it. It fixes some bugs related to Auriol and compatible weather stations and greatly improves reception.
When possible please report back if it fixed the reported issues.

Keep in mind that the Auriol weather stations send some data packets at intervals which can be great than 2 minutes (temperature is one of them).
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply
#6
(22-08-2019, 21:18)engolling Wrote: Can you activate the Auriol debug messages as the bottom of the config options and see what the serial monitor of arduino is showing?

regards,
engolling

Unfortunately activating the the Auriol debug messages only shows a brief info about incoming data from the wireless rain gauge. I used that instrument for long time, and all the other instruments (wind, T/H, etc) connected to a WeatherDuino TX unit.
Reply
#7
(22-08-2019, 21:18)engolling Wrote: Can you activate the Auriol debug messages as the bottom of the config options and see what the serial monitor of arduino is showing?

regards,
engolling

I've tried your recommendation, I think the result is not really enlightening.


Attached File(s) Image(s)
   
WeatherDuino Pro2 Compact + Auriol HT13726
Reply
#8
(23-08-2019, 03:10)Werk_AG Wrote: Hi Sun_Dancer,

Please download latest WeatherDuino Pro2 Compact (v3.2_b002) software and install it. It fixes some bugs related to Auriol and compatible weather stations and greatly improves reception.
When possible please report back if it fixed the reported issues.

Keep in mind that the Auriol weather stations send some data packets at intervals which can be great than 2 minutes (temperature is one of them).

Hello Werk_AG, thanks for the update. Unfortunately, it has not corrected the mistakes for me. The problems with the temperature and humidity values still exist. I ordered an outdoor sensor from Ventus (W044). This should probably work with the Auriol weather station. I hope that he works with the Pro2 Compact and, yes, then I'm curious how the values will turn out.
In any case, the speed of the connection has improved.
greetings
WeatherDuino Pro2 Compact + Auriol HT13726
Reply
#9
(26-08-2019, 01:59)Sun_Dancer Wrote:
(22-08-2019, 21:18)engolling Wrote: Can you activate the Auriol debug messages as the bottom of the config options and see what the serial monitor of arduino is showing?

regards,
engolling

I've tried your recommendation, I think the result is not really enlightening.

Hi,

WeatherDuino outputs debug messages to the serial monitor at 19200 baud. Please try open the serial monitor at 19200 baud instead of 115200.

(26-08-2019, 02:07)Sun_Dancer Wrote:
(23-08-2019, 03:10)Werk_AG Wrote: Hi Sun_Dancer,

Please download latest WeatherDuino Pro2 Compact (v3.2_b002) software and install it. It fixes some bugs related to Auriol and compatible weather stations and greatly improves reception.
When possible please report back if it fixed the reported issues.

Keep in mind that the Auriol weather stations send some data packets at intervals which can be great than 2 minutes (temperature is one of them).

Hello Werk_AG, thanks for the update. Unfortunately, it has not corrected the mistakes for me. The problems with the temperature and humidity values still exist. I ordered an outdoor sensor from Ventus (W044). This should probably work with the Auriol weather station. I hope that he works with the Pro2 Compact and, yes, then I'm curious how the values will turn out.
In any case, the speed of the connection has improved.
greetings


Temporarily I have reactivated my old Auriol weather station in an attempt to reproduce the reported behaviour, up to now I haven't see any problem with the temperature readings, both systems update almost at the same time, however I will continue monitoring the system to see if something wrong comes out.

   

   


Weatherduino only receives Temp / Hum data from channel 1, which is the default channel for the embedded T/H sensor on the Auriol transmitter unit, so most probably it will not get data from any other outdoor sensor. If you have any other indoor or outdoor 433MHz RF sensors, try temporarily disable them to check if this could be the cause of the corrupted T/H data.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply
#10
Hi Sun_Dancer,

I just reviewed the thread - does only the temperature / humidity values not work or wind and rain too?
That's not clear for me upto now`.
And - second - Question: Do the wrong temp / hum values change or are they stuck?

Regards,
engolling
Reply




Users browsing this thread: 1 Guest(s)