This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Battery voltage calibration
#1
I am gradually getting my Weatherduino system up and running, it comprises a PRO2 TX PCB v 2.50, PRO2 RX+ v4.03 and a WD 4PRO v1.30Rev_A.

The indicated battery voltage is reading exactly ½ the actual voltage, e.g. my power supply is set to 10v, but the RX and WD both shown the battery voltage is 5v, I have used precision resistors so don’t believe this to be a hardware problem. Should I be adjusting something in the TX software or in the RX?

Thanks Andy
Reply
#2
(13-04-2019, 18:07)atbukc Wrote: I am gradually getting my Weatherduino system up and running, it comprises a PRO2 TX PCB v 2.50, PRO2 RX+ v4.03 and a WD 4PRO v1.30Rev_A.

The indicated battery voltage is reading exactly ½ the actual voltage, e.g. my power supply is set to 10v, but the RX and WD both shown the battery voltage is 5v, I have used precision resistors so don’t believe this to be a hardware problem. Should I be adjusting something in the TX software or in the RX?

Thanks Andy

Hello Andy,

Some time ago, we have introduced some changes on the way the Battery Voltage data is processed, however the software for the older Pro2 receivers wasn't been updated to deal with those changes.
When you read this post, probably I already published an updated software version (WeatherDuino Pro2 AT328 RX v4.0_b002) which will solve this issue.
Please note that there will be a new setting in the Config_Options.h, set it accordingly to the software version you ae using in your TX unit.

Code:
// --------------------------------------------------------------------------------------
//   Transmitter Software Version
// --------------------------------------------------------------------------------------
#define TX_SOFTWARE_VERSION  7    // Use main version number only (This setting affects VBat readings)
                                 // Hint: TX software versions released prior to Dec 2018 are all < 7

Regards
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply




Users browsing this thread: 1 Guest(s)