WeatherDuino Forum
Comms Problems - Printable Version

+- WeatherDuino Forum (https://www.meteocercal.info/forum)
+-- Forum: WeatherDuino Pro2 Weather Stations (https://www.meteocercal.info/forum/Forum-WeatherDuino-Pro2-Weather-Stations)
+--- Forum: General Discussion (https://www.meteocercal.info/forum/Forum-General-Discussion--23)
+--- Thread: Comms Problems (/Thread-Comms-Problems)

Pages: 1 2 3 4 5


RE: Comms Problems - GreggWardNZ - 17-10-2015

The Rx unit is still working perfectly, so far, with no dropped data. Thanks Werk_AG, you were correct.

I will look at getting a new 12v power supply today. What max current should I look for. The faulty power supply has a max output of 450mA. When I plug this power supply in, the backlight on my attached LCD seems to be overpowered and makes the text on the LCD harder to read. Could this be an indication of too much current being sent to the Rx unit?


RE: Comms Problems - Werk_AG - 18-10-2015

Thanks for the good news.

Fortunately you noticed that RX starts to receive data when you remove the 12V power supply, otherwise maybe we still would be thinking about what parts to change.

450mA should be enough for the RX unit, but probably your power supply it's not enable to supply it with a stable 12V output. I always used those chinese small 12V 1A wall adapters and never had any problem.

Regarding the LCD, you should adjust the contrast level when it is powered by the external 12V power supply.
In the back of the LCD (I2C adapter) you should find a pot, adjust it with a screw tool to suite your taste. It will also be readable when powered only by USB.

Let us know!


RE: Comms Problems - GreggWardNZ - 18-10-2015

(18-10-2015, 01:48)Werk_AG Wrote: Thanks for the good news.

Fortunately you noticed that RX starts to receive data when you remove the 12V power supply, otherwise maybe we still would be thinking about what parts to change.

450mA should be enough for the RX unit, but probably your power supply it's not enable to supply it with a stable 12V output. I always used those chinese small 12V 1A wall adapters and never had any problem.

Regarding the LCD, you should adjust the contrast level when it is powered by the external 12V power supply.
In the back of the LCD (I2C adapter) you should find a pot, adjust it with a screw tool to suite your taste. It will also be readable when powered only by USB.

Let us know!

Thanks again for your help Werk_AG.


RE: Comms Problems - Palmyweather - 18-10-2015

Just wondering, if a DC "Switch Mode" power supply is being used could be causing noise to be introduced into the circuit which may cause interference? Or even bigger chance if the power supply was an unregulated DC Switch Mode power supply?


RE: Comms Problems - uncle_bob - 18-10-2015

Good point PW. Could be like those cheap LED lamp drivers that wipe out the AM/ADSL/Ham radio spectrum.


RE: Comms Problems - Palmyweather - 18-10-2015

That was my thought exactly.

Maybe some RF suppression snap-on Ferrite rings may help over the power supply cable, or an electrolytic capacitor over the 12V power source to help keep the switch mode power supply more stable?


RE: Comms Problems - GreggWardNZ - 20-10-2015

The Rx unit has been working beautifully with just the USB connection powering it.

I received a new 12V 1A regulated switching power supply, today, so tried plugging that in to see how it would work. As soon as I plugged it into the Rx unit, the Tx LED stopped flashing and the data stopped updating. I also noticed that Cumulus started outputting messages that the weather station had stopped responding. Removing the power supply and restarting Cumulus and my weather station was back up and running.

For the moment I am just going to leave my Rx unit being powered by USB.


RE: Comms Problems - Werk_AG - 20-10-2015

Maybe there is a problem with your 7809 regulator.
Do you use a tantalum capacitor or just an electrolytic capacitor at C2? If just an electrolytic capacitor, try to add a 100nF capacitor in parallel to it. You can solder it in the underside of the board.

For long term use it's not recommended keep it powered by just USB, especially if you have the TX module attached, to broadcast info to Wireless Display units.


RE: Comms Problems - GreggWardNZ - 21-10-2015

Thanks Werk_AG, I had a quick look at the board last night and looks to be a tantalum capacitor that I installed to C2. I will try and have a look at the 7809 regulator, in the next day or two.


RE: Comms Problems - AllyCat - 22-10-2015

Hi,

I don't know the architecture of the Receiver Software, but could severe Radio Frequency Interference be "blocking" the reception. I was going to suggest possible RFI sources a few days ago.

Is the switching-mode converter of known "good design" (or ebay no-name Chinese) and is the replacement the same model?

Cheers, Alan.