WeatherDuino Forum
compiling Error for Update RX_v4.1_b001 - Printable Version

+- WeatherDuino Forum (https://www.meteocercal.info/forum)
+-- Forum: Weather Stations - WeatherDuino Pro2 Line (https://www.meteocercal.info/forum/Forum-Weather-Stations-WeatherDuino-Pro2-Line)
+--- Forum: Software Questions (https://www.meteocercal.info/forum/Forum-Software-Questions)
+--- Thread: compiling Error for Update RX_v4.1_b001 (/Thread-compiling-Error-for-Update-RX-v4-1-b001)



compiling Error for Update RX_v4.1_b001 - xxDvDxx - 06-12-2020

Hi, i tried to update the Pro2 compact to RX_v4.1_b001 but i found some errors:

Arduino:1.8.13 (Windows 10), Scheda:"LOLIN(WEMOS) D1 R2 & mini, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 4MB (FS:2MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 921600"

WeatherDuino_P2ESP8266_RX_v4.1_b001:148:46: error: 'AQtext_10' does not name a type
                                              AQtext_10, AQtext_11, AQtext_12, AQtext_13, AQtext_14 };
                                              ^
WeatherDuino_P2ESP8266_RX_v4.1_b001:148:100: error: expected declaration before '}' token
                                              AQtext_10, AQtext_11, AQtext_12, AQtext_13, AQtext_14 };
                                                                                                    ^
exit status 1
'AQtext_10' does not name a type




 line 148                                            AQtext_10, AQtext_11, AQtext_12, AQtext_13, AQtext_14 };



Any suggest?


   


RE: compiling Error for Update RX_v4.1_b001 - Werk_AG - 07-12-2020

Hi,

From your picture of the Arduino IDE screen I see that line 147 isn't equal to published code.
Please check if you are really using the published Pro2 compact to RX_v4.1_b001 version and report back.

Regards
Werk_AG


RE: compiling Error for Update RX_v4.1_b001 - xxDvDxx - 08-12-2020

(07-12-2020, 03:52)Werk_AG Wrote:  Hi,

From your picture of the Arduino IDE screen I see that line 147 isn't equal to published code.
Please check if you are really using the published Pro2 compact to RX_v4.1_b001 version and report back.

Regards
Werk_AG
Hi, i found the error and now its compiling with no errors,  just i dont know why the data from the rain gauce sensor doesnt appear in the display, in the auriol unit it's working normally and the Compact rx is placed next to the auriol display, so can't be anything about battery or bad reception.  How i can check about it?  Hope it doesnt depending from the WU site witch were collecting data, that stopped to work in october and i dont know why..   the accout expiration its on january 2021 so dont know.
Let me know if u got some idea, Thnks


p.s.
I solved that API key question i sent u on PM , sorry to bother you in private also.