WeatherDuino Forum

Full Version: AQM issue_freezing
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi,
My new is freezing as shown in the attached photo, and it is reset with a power down /up and is OK again for a few days.
Any ideas???
Hi,

I see that the Temp / Hum readings are wrong too. Seems a problem in the I2C bus.
Check the connections of the T / H sensor as also the OLED display. Is it welded directly on the pcb?
I have a similar issue with the temp reading on the display showing 998C. The humidity reading is ok. I have checked all solder joints and touched up. These don't seem to be causing the issue. The temp/humidity module was taken from a AQM original version and was working ok in that unit.
Just to eliminate a possibility, what speed are both of you running the Wemos D1 mini? 80 or 160Mhz?
(03-08-2019, 00:54)Werk_AG Wrote: [ -> ]Just to eliminate a possibility, what speed are both of you running the Wemos D1 mini? 80 or 160Mhz?

I have reloaded the software using both 80Mhz and 160Mhz with same result, ie temp displaying 998.0C and humidity currently 56.4%.
Hi,

In your case the problem seems to be related to the sensor. Which type of T / H sensor are you using? HTU21D or SHT31?
For the Wemos D1 use 80Mhz.
(03-08-2019, 06:21)Werk_AG Wrote: [ -> ]Hi,

In your case the problem seems to be related to the sensor. Which type of T / H sensor are you using? HTU21D or SHT31?
For the Wemos D1 use 80Mhz.



HTU21D
Werk,
I am using HTU21 as well, but am currently away for a couple of weeks, but as to the speed I have no idea or was aware there was a choice
Regards
Jim
Once the HTU21 can't be directly attached to the PCB (pinout on the PCB is for the SHT31) make sure the cables between the PCB and sensor are the shortest as possible.
The OLED display should be connected directly on the PCB.

I have just tested an unit with the HTU21 and latest software, and it is working fine. Double check if the installed HTU21 library is the one supplied with the software package.
I have taken the path of least resistance and installed a SHT31 and all is now working fine. I had a quick look but could not find reference to an alternative installation for the HTU21 module.
Pages: 1 2