This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WeeWX connection problem
#1
I first looked in this forum but did not find useable info on WeeWX so I had to open a new thread.

After Cumulus MX crashed after several attempts, I wanted to try WeeWX...
Cumulus MX did work perfectly on my Raspberry Pi 3B+ but after 3-4 hours it grinds to a halt.

But WeeWX did not work at all:

1. Raspberry Pi 3B+ --> WeatherDuino Pro2 plus
2. I did set the WD config option to '1' (for WeeWX)
3. serial port used: /dev/ttyACM0
4. after WeeWX starts, the WD led's indicate serial communication after which the WD resets itself

log:

pi@raspberrypi:~ $ sudo tail -f /var/log/syslog
Oct 19 11:21:21 raspberrypi systemd[1]: Starting LSB: weewx weather system...
Oct 19 11:21:22 raspberrypi weewx[1245]: engine: Initializing weewx version 3.9.2
Oct 19 11:21:22 raspberrypi weewx[1245]: engine: Using Python 2.7.16 (default, Apr  6 2019, 01:42:57) #012[GCC 8.2.0]
Oct 19 11:21:22 raspberrypi weewx[1245]: engine: Platform Linux-4.19.75-v7+-armv7l-with-debian-10.1
Oct 19 11:21:22 raspberrypi weewx[1245]: engine: Locale is 'en_GB.UTF-8'
Oct 19 11:21:22 raspberrypi weewx[1245]: engine: pid file is /var/run/weewx.pid
Oct 19 11:21:22 raspberrypi weewx[1249]: engine: Using configuration file /home/weewx/weewx.conf
Oct 19 11:21:22 raspberrypi weewx[1249]: engine: Loading station type Vantage (weewx.drivers.vantage)
Oct 19 11:21:22 raspberrypi weewx[1234]: Starting weewx weather system: weewx.
Oct 19 11:21:22 raspberrypi systemd[1]: Started LSB: weewx weather system.
Oct 19 11:21:35 raspberrypi weewx[1249]: vantage: Unable to wake up console
Oct 19 11:21:35 raspberrypi weewx[1249]: engine: Import of driver failed: Unable to wake up Vantage console (<class 'weewx.WakeupError'>)
Oct 19 11:21:35 raspberrypi weewx[1249]: engine: Unable to load driver: Unable to wake up Vantage console
Oct 19 11:21:35 raspberrypi weewx[1249]:     ****  Exiting...

Any suggestions? I don't know where to start looking ...
Thank you!
Reply
#2
Hello,

I'm using WeeWx with my Pro2Plus and it runs fine.
According to the log, it seems that the WeatherDuino does not answer. Are you sure, that the WeatherDuino has already fully startet and received some RF package before starting WeeWx?
Be sure that the programming switch is in "run" mode so the controller does not reboot when WeeWx connects.

Code:
 # WEEWX CONFIGURATION FILE
#
# Copyright (c) 2009-2015 Tom Keffer <tkeffer@gmail.com>
# See the file LICENSE.txt for your rights.

##############################################################################

# This section is for general configuration information.

# Set to 1 for extra debug info, otherwise comment it out or set to zero
debug = 0

loop_on_init = True
You can also add the loop_on_init function in your weewx.conf - it should prevent it stopping in any case.

Regards,
engolling
Reply
#3
(19-10-2019, 22:20)engolling Wrote: Hello,

I'm using WeeWx with my Pro2Plus and it runs fine.
According to the log, it seems that the WeatherDuino does not answer. Are you sure, that the WeatherDuino has already fully startet and received some RF package before starting WeeWx?
Be sure that the programming switch is in "run" mode so the controller does not reboot when WeeWx connects.
Code:
 # WEEWX CONFIGURATION FILE
#
# Copyright (c) 2009-2015 Tom Keffer <tkeffer@gmail.com>
# See the file LICENSE.txt for your rights.

##############################################################################

# This section is for general configuration information.

# Set to 1 for extra debug info, otherwise comment it out or set to zero
debug = 0

loop_on_init = True
You can also add the loop_on_init function in your weewx.conf - it should prevent it stopping in any case.

Regards,
engolling

Thank you, your reply is very much appreciated!  I have some things to check.
Will report back ...
Reply
#4
(20-10-2019, 09:25)edr1924 Wrote:
(19-10-2019, 22:20)engolling Wrote: Hello,

I'm using WeeWx with my Pro2Plus and it runs fine.
According to the log, it seems that the WeatherDuino does not answer. Are you sure, that the WeatherDuino has already fully startet and received some RF package before starting WeeWx?
Be sure that the programming switch is in "run" mode so the controller does not reboot when WeeWx connects.
Code:
 # WEEWX CONFIGURATION FILE
#
# Copyright (c) 2009-2015 Tom Keffer <tkeffer@gmail.com>
# See the file LICENSE.txt for your rights.

##############################################################################

# This section is for general configuration information.

# Set to 1 for extra debug info, otherwise comment it out or set to zero
debug = 0

loop_on_init = True
You can also add the loop_on_init function in your weewx.conf - it should prevent it stopping in any case.

Regards,
engolling

Thank you, your reply is very much appreciated!  I have some things to check.
Will report back ...

forgot about the switch... setting to 'run' did the trick...
Thanks!
Reply
#5
(20-10-2019, 12:51)edr1924 Wrote: ...

forgot about the switch... setting to 'run' did the trick...

Stop WeeWx, and turn it to PROGRAM position every time you need to upgrade software, otherwise software upgrade will fail.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel



Reply
#6
Hi,
Can I please confirm, the run/program is the VP1 pins? And is 'run' when these are closed?
Reply
#7
(13-11-2019, 04:48)mikeyk Wrote: Hi,
Can I please confirm, the run/program is the VP1 pins? And is 'run' when these are closed?

 Exactly. I confirm.
Reply
#8
Hello Everybody,
Sorry For my bad English.
I'm new user WD.
Do you know how to do to use with Weewx?
I have a strange  messages:
sys_log file:
Feb 22 02:20:46 local weewx[11644]: vantage: Unable to wake up console
Feb 22 02:20:46 local weewx[11644]: engine: Import of driver failed: Unable to wake up Vantage console ( Feb 22 02:20:46 local weewx[11644]: engine: Unable to load driver: Unable to wake up Vantage console
Feb 22 02:20:46 local weewx[11644]:     ****  Exiting...

kernel log file:
Feb 22 02:20:42  kernel: [ 6681.038151] ch341-uart ttyUSB5: usb_serial_generic_write_bulk_callback - nonzero urb status: -71

For my example, I use
I use /dev/ttyUSB5 (not raspberry)
With my FO station connection was ok. (Of course, I deconnected FO)

Have you got an idea?

I just config weewx.conf files. I don't to do nothing in WD software.

Thanks.
Reply
#9
Hi,
a few ideas where you could start looking:

Did you close the "run" switch?
If not the WeatherDuino will restart each time WeeWx is trying to connect.

Another possible thing: do you have the ch341 drivers intalled?

Last but not least, maybe you have selected the wrong device the WeatherDuino has a ch341 UART --> USB converter which emulates a virtual serial device.
At the moment you are "using" the USB device itself.
But here I'm at the moment very unsure because I can not check this on a linux machine at the moment.
Reply
#10
Hi lamda,

When asking for help, its good specifying which system you are using, this also help others to help you.. Not all WeatherDuino systems are equal.
I know your receiver is a Pro2 Compact, but the others don't know, and when trying to help you, may be giving you hints which doesn't apply to your system, which is the case of the "Prog/ Run" switch which only exists on the Pro2 PLUS receiver.

As previously said by PM, I believe your problem is a wrong selection of the serial port. I'm not an expert is Linux, but there are ways to find the name of the serial port attributed to the Pro2 Compact.

Regarding the serial port, follow Engolling hints on previous message.
Reply




Users browsing this thread: 1 Guest(s)