Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5

WeatherDuino Pro2 Compact v5.0_b001 no WIFI connection
#1

After the update v5.0_b001, the Pro2 Compact no longer connects to the WIFI network. If I flash back to V4.3, the connection is restored.

WeatherDuino 4Pro, Auriol HT13726 Rain Gauge, Davis wind vane / anemometer, UV / solar module​​​​​​​ + Millenium Falcon
PWS ILEIPZ27
Reply
#2

(07-04-2021, 21:58)Sun_Dancer Wrote:  After the update v5.0_b001, the Pro2 Compact no longer connects to the WIFI network. If I flash back to V4.3, the connection is restored.

Hi Sun_Dancer,

Many thanks for the feedback. Indeed, I found a typo mistake on the initial release. Blush

Quote:The initial release has a typo mistake on the Config_Options.h file. On line 312, where it says ENABLE INTERNET, should be ENABLE_WIFI
This typo causes that there is no WiFi connection, and its fixed on the 2021-04-07 update.

Please download the Pro2 Compact software package again.



Reply
#3

(07-04-2021, 21:58)Sun_Dancer Wrote:  After the update v5.0_b001, the Pro2 Compact no longer connects to the WIFI network. If I flash back to V4.3, the connection is restored.
Further to your issue.

I also get compilation errors if I enable 'BROADCAST_DATA' in config_options when testing compilation and have yet to install on my unit.  
 
PHP Code:
C:\Users\xxxxxx\Documents\Arduino\WeatherDuino_Pro2_Compact_v5.0_b001_20210404\WeatherDuino_Pro2_Compact\software\RX software\WeatherDuino_P2ESP8266_RX_v5.0_b001\RX_TX.inoIn function 'void BroadcastData(int, long int, long int, long int, long int)':
RX_TX:536:6error'udp1' was not declared in this scope
      udp1
.begin(UDP_BROADCAST_PORT);
      ^
exit 
status 1
'udp1' was not declared in this scope 

if I leave broadcast_data disabled it compiles fine but have not deployed to a unit, since i need this flag enable to pass data to my display units.
Reply
#4

(08-04-2021, 00:11)bgedward Wrote:  
(07-04-2021, 21:58)Sun_Dancer Wrote:  After the update v5.0_b001, the Pro2 Compact no longer connects to the WIFI network. If I flash back to V4.3, the connection is restored.
Further to your issue.

I also get compilation errors if I enable 'BROADCAST_DATA' in config_options when testing compilation and have yet to install on my unit.  
 
PHP Code:
C:\Users\xxxxxx\Documents\Arduino\WeatherDuino_Pro2_Compact_v5.0_b001_20210404\WeatherDuino_Pro2_Compact\software\RX software\WeatherDuino_P2ESP8266_RX_v5.0_b001\RX_TX.inoIn function 'void BroadcastData(int, long int, long int, long int, long int)':
RX_TX:536:6error'udp1' was not declared in this scope
      udp1
.begin(UDP_BROADCAST_PORT);
      ^
exit 
status 1
'udp1' was not declared in this scope 

if I leave broadcast_data disabled it compiles fine but have not deployed to a unit, since i need this flag enable to pass data to my display units.

I think this can be ignored now and was obviously related.  I have now applied the fix as mentioned in the previous post now of enable_wifi in lieu of enable_internet on line 312 of config_options and now compiles fine.  Time to deploy!
Reply
#5

(08-04-2021, 00:22)bgedward Wrote:  I think this can be ignored now and was obviously related.  I have now applied the fix as mentioned in the previous post now of enable_wifi in lieu of enable_internet on line 312 of config_options and now compiles fine.  Time to deploy!

Hi bgedward,

Yes, it is related. Error is fixed on latest Pro2 Compact update.
Thanks for the report.


(08-04-2021, 00:11)bgedward Wrote:  if I leave broadcast_data disabled it compiles fine but have not deployed to a unit, since i need this flag enable to pass data to my display units.

I'm so used to my Wireless Display units that I can't dispense them. The "broadcast data" is a must for me too Wink
Reply




Users browsing this thread: 1 Guest(s)