This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Pro2 Compact] Problem with ESP8266 uploader
#1
Hi,
I just had an error message when I tried to do the ESP8266 Sketch Data Upload. After copying the 'tools' directory to my 'sketches' directory I received the following error when I tried to do the upload:
Code:
Arduino: 1.8.12 (Linux), Board: "LOLIN(WEMOS) D1 R2 & mini, 80 MHz, Flash, Legacy (new can return nullptr), All SSL ciphers (most compatible), 4MB (FS:2MB OTA:~1019KB), v2 Lower Memory, Disabled, None, Only Sketch, 921600"

[SPIFFS] data    : /home/gord/Arduino/WeatherDuino_Pro2_Compact v3/software/RX software/WeatherDuino_P2ESP8266_RX_v3.1_b012/data
[SPIFFS] size    : 2024
[SPIFFS] page    : 256
[SPIFFS] block   : 8192
/fonts/ArialBold11LEA.vlw
/fonts/ArialBold11.vlw
/fonts/NotoSansBold14.vlw
/fonts/NotoSansBold14LEA.vlw
/icons/WDicon.bmp
/icons/tree1.bmp
/icons/termometro.bmp
/icons/home.bmp
/icons/home1.bmp
/icons/tree.bmp
/icons/moisture.bmp
/splash/Pro2Compact_Splash.jpg
/splash/WDlogo.jpg
/icon50/thunderstorm.bmp
/icon50/rain.bmp
/icon50/fog.bmp
/icon50/unknown.bmp
/icon50/hail.bmp
/icon50/cloudy.bmp
/icon50/clear-day.bmp
/icon50/snow.bmp
/icon50/lightRain.bmp
/icon50/sleet.bmp
/icon50/drizzle.bmp
/icon50/wind.bmp
/icon50/clear-night.bmp
/icon50/partly-cloudy-night.bmp
/icon50/partly-cloudy-day.bmp
[SPIFFS] upload  : /tmp/arduino_build_177758/WeatherDuino_P2ESP8266_RX_v3.1_b012.spiffs.bin
[SPIFFS] address  : 0x200000
[SPIFFS] reset    : --before default_reset --after hard_reset
[SPIFFS] port     : /dev/ttyUSB0
[SPIFFS] speed    : 921600
[SPIFFS] python   : python
[SPIFFS] uploader : /home/gord/.arduino15/packages/esp8266/hardware/esp8266/2.6.3/tools/upload.py

usage: esptool [-h] [--chip {auto,esp8266,esp32}] [--port PORT] [--baud BAUD]
               [--before {default_reset,no_reset,no_reset_no_sync}]
               [--after {hard_reset,soft_reset,no_reset}] [--no-stub]
               [--trace] [--override-vddsdio [{1.8V,1.9V,OFF}]]
               {load_ram,dump_mem,read_mem,write_mem,write_flash,run,image_info,make_image,elf2image,read_mac,chip_id,flash_id,read_flash_status,write_flash_status,read_flash,verify_flash,erase_flash,erase_region,version}
               ...
esptool: error: unrecognized arguments: --end
SPIFFS Upload failed!

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I downloaded the 'esp8266fs.jar' file from GitHub and copied it to the same place and everything worked fine.
Just thought you might like to know.

Cheers,
Gord
Reply
#2
Hi Gord,

That error happened because you are using ESP8266 boards manager v2.6.3, while the code was test under v2.4.2

Quote:/home/gord/.arduino15/packages/esp8266/hardware/esp8266/2.6.3/

If you experience any strange behaviour like freezes, revert to v2.4.2 - I don't know if it works stable with v2.6.3

Thanks
Rgs
Reply
#3
OK, thanks for the reply, good to know.
As I said, it seemed to work if I used the jar file from GitHub.

Gord
Reply




Users browsing this thread: 1 Guest(s)