This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Uma Duvida
#1
Bom dia

Se eu ligar a placa TX a Placa RX pelo pino DATA o led RX não devia piscar a mesma cadencia do TX?
Cuprimentos
Reply
#2
Smile
Sim deveria, caso tenha a opção relay data activa no software, e ambas as boards tenham GND comum.
Cumprimentos.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel

[Image: banner_EN.php]

Reply
#3
(12-02-2018, 18:16)Werk_AG Wrote: Smile
Sim deveria, caso tenha a opção relay data activa no software, e ambas as boards tenham GND comum.
Cumprimentos.

Onde encontro essa configuração. pois liguei o meu tx ao rx com os GND comum e não pisca
Obrigado
Reply
#4
RX software

Code:
// --------------------------------------------------------------------------------------
//   Broadacasting settings for Wireless Display Units
// --------------------------------------------------------------------------------------
#define Relay_Data       1   // 0= Disables Data Relay, 1= Enables Data Relay

Note que isso só deverá funcionar com cabos muito curtos entre a placa TX e RX.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel

[Image: banner_EN.php]

Reply
#5
(12-02-2018, 19:08)Werk_AG Wrote: RX software

Code:
// --------------------------------------------------------------------------------------
//   Broadacasting settings for Wireless Display Units
// --------------------------------------------------------------------------------------
#define Relay_Data       1   // 0= Disables Data Relay, 1= Enables Data Relay

Obrigado pela rapida resposta .
Essa opção ja esta ativa por defeito no programa. mas continua sem piscar.
Vou queimar mais umas pestanas a tentar perceber porque 
cumprimentos
Reply
#6
O RX Led pisca tendo a TX a enviar via radio?

Qual a versão da sua placa RX?
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel

[Image: banner_EN.php]

Reply
#7
(12-02-2018, 19:12)Werk_AG Wrote: O RX Led pisca tendo a TX a enviar via radio?

Não tenho os modulos de radio ainda e queria testar a ver se dava para ligar o modulo universal tx ao modulo rx por cabo.
O modulo universal tx pisca a uma cadencia de 3 a 4 segundos
A versão da placa rx é a 2.00
Reply
#8
Se a sua RX board é uma Pro2 PLUS v2.xx, o RX LED deveria piscar independentemente da funcão Relay_Data estar activa ou não, se a versão é inferior a v2.x então sim a funcão Relay_Data  deverá estar activa.

Aquilo que está a tentar fazer, pelo mens funcionava com a livraria virtualwire, nunca testei com a RadioHead, mas deverá funcionar igualmente.
- Verifique se tem os mesmos Station_ID configurados quer no software TX quer RX.

Supondo que tem a TX unit configurada como unit 0, verifique se o software RX está configurado para receber da TX 0

Code:
// --------------------------------------------------------------------------------------
//   Define the source of your main outside sensors
// --------------------------------------------------------------------------------------
// ---- If you are using just one TX board, the source for all items should be equal to your single TX Unit ID (most likely zero).
// ---- Define the source of your main Temperature / Humidity sensor
#define TH_OutUnit       0   // 0= Temp/Hum sensor connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Temp / Hum
// ---- Define the source of your Main Wind sensor
#define WIND_OutUnit     0   // 0= Wind instruments connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Wind Speed & Dir
// ---- Define the source of your main Rain Gauge
#define RAIN_OutUnit     0   // 0= Rain Gauge connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Rain Gauge
// ---- Define the source of your main Solar Radiation sensor
#define SR_OutUnit       9   // 0= Solar Radiation sensor connected to TX_Unit 0, 1= for TX_Unit1, ..., 9 for not used
// ---- Define the source of your main UV sensor
#define UV_OutUnit       0  // 0= UV sensor connected to TX_Unit 0, 1= for TX_Unit1, ..., 9 for not used
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel

[Image: banner_EN.php]

Reply
#9
(12-02-2018, 19:28)Werk_AG Wrote: Se a sua RX board é uma Pro2 PLUS v2.xx, o RX LED deveria piscar independentemente da funcão Relay_Data estar activa ou não, se a versão é inferior a v2.x então sim a funcão Relay_Data  deverá estar activa.

Aquilo que está a tentar fazer, pelo mens funcionava com a livraria virtualwire, nunca testei com a RadioHead, mas deverá funcionar igualmente.
- Verifique se tem os mesmos Station_ID configurados quer no software TX quer RX.

Supondo que tem a TX unit configurada como unit 0, verifique se o software RX está configurado para receber da TX 0

Code:
// --------------------------------------------------------------------------------------
//   Define the source of your main outside sensors
// --------------------------------------------------------------------------------------
// ---- If you are using just one TX board, the source for all items should be equal to your single TX Unit ID (most likely zero).
// ---- Define the source of your main Temperature / Humidity sensor
#define TH_OutUnit       0   // 0= Temp/Hum sensor connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Temp / Hum
// ---- Define the source of your Main Wind sensor
#define WIND_OutUnit     0   // 0= Wind instruments connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Wind Speed & Dir
// ---- Define the source of your main Rain Gauge
#define RAIN_OutUnit     0   // 0= Rain Gauge connected to TX_Unit 0, 1= for TX_Unit 1, ..., 3 for Auriol RF Rain Gauge
// ---- Define the source of your main Solar Radiation sensor
#define SR_OutUnit       9   // 0= Solar Radiation sensor connected to TX_Unit 0, 1= for TX_Unit1, ..., 9 for not used
// ---- Define the source of your main UV sensor
#define UV_OutUnit       0  // 0= UV sensor connected to TX_Unit 0, 1= for TX_Unit1, ..., 9 for not used

Sim ja revi essas configurações e estão confirmadas
Reply
#10
Pode dar-se o caso de o LED estar com algum problema.
Já tem algum ecran ligado à placa RX, de forma a poder verificar se realmente a RX está a descodificar os dados enviados pela TX.


Suponho que está a usar software com as mesmas livrarias radio quer no software TX quer RX, virtualwire e radiohead não são compatíveis.
MeteoCercal - Air Quality Data
Click here to watch at my ThingSpeak channel

[Image: banner_EN.php]

Reply




Users browsing this thread: 1 Guest(s)